Recommender sunset period

We first released our EPrints recommender (previously called ‘CORE Widget’) in April 2013 and since then, have made many improvements to it and our recommendation systems. We blogged about our most recent changes which you can read about here.

As a result, it means that we will stop supporting old versions of the recommender. If you installed the recommender on or before the 10th October 2016, you will need to upgrade.

Any old version of the recommender will cease to work on Monday 20th February 2016.

  • How do I know if I need to upgrade?

In EPrints, visit ‘Admin’, ‘System Tools’, ‘Eprints Bazaar’. In the list of installed plugins, if you see ‘CORE Widget’ or version 0.x.x, then you will need to upgrade. For example, if you see the following information, you will need to upgrade:An old version of the CORE Recommender

Notice how the title is CORE Widget and the website link is

If you are on the latest version, you will see the name as ‘CORE Recommender’, the version will be 1.x.x. An example of this is:

A CORE Recommender EPrints installation at the latest version

Here, the title is CORE Recommender and has a link to our new website address

For non-EPrints installations:
We previously offered a Javascript installation process. The best way to know if you need to upgrade is if the API key you are using is longer than 20 characters. If you are still unsure, please get in touch.

  • Can I use my old API key using the upgraded recommender?

No, you will need to register for a recommender ID. Your existing API key will continue to be valid for our API v2 requests.

If you need any help with upgrading or have any further questions, please contact us or write a comment below. We’ll be happy to help.